MACD鳄鱼嘴选股公式,求写一个macd的选股公式

  Q1:求写一个macd的选股公式

DIFF:= EMA(CLOSE,10) - EMA(CLOSE,30),colorwhite;
DEA: =EMA(DIFF,9),coloryellow;
MACD: =2*(DIFF-DEA), COLORSTICK;a:=(cross(diff*0.98,dea) or cross(diff,dea)) and dea>0.95; b:=vol>ref(vol,1) and ref(vol,1) >ref(vol,2) ;买:A AND B 粘贴后,可用

  Q2:绝佳(MACD将死不死)选股公式,通达信已测试

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
XG1:=REF(DIF,1)=REF(DEA,1) AND MACD>REF(MACD,1) AND V>REF(V,1)*1.5 AND CROSS(C,MA(C,20)) AND MA(V,5)>MA(V,10);
XG2:=REF(BARSLASTCOUNT(MACD>0 AND MACD<REF(MACD,1)),1)>2 AND MACD>REF(MACD,1) AND V>REF(V,1)*1.5 AND C>MA(C,20) AND MA(V,5)>MA(V,10);
XG:XG1 OR XG2;

  Q3:请老师编写一个macd的选股公式通达信的谢谢

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
SX:=BARSLAST(CROSS(DEA,DIFF))+1;
JX:=BARSLAST(CROSS(DIFF,DEA))+1;
T1:=IF(JX=1 AND DIFF>REF(DIFF,REF(JX,1)+1),1,0);
T2:=IF(JX=1 AND LLV(DIFF,SX)>REF(LLV(DIFF,SX),SX),1,0);
XG:T1 OR T2;

  Q4:请老师帮忙写一个MACD中DEA上涨的选股公式

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
XG:DEA>REF(DEA,1);

(信号太多了)

DEA转头向上的选股:

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
XG:REF(DEA,1)<REF(DEA,2) AND DEA>REF(DEA,1);

  Q5:编写一个通达信选股公式,MACD周线金叉

选股公式如下,选股周期选择周线,

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIF,9);

XG:BARSLAST(CROSS(DIF,DEA))>0 AND DIF>DEA;

  Q6:求一个同花顺选股公式:要求macd指标的macd值小于等于0

红色转为绿色的第一天
SELECT CROSS(0,MACD);
------------------------------------------
不知道别人给你的是怎么做的,就这么简单就行